Add integration test to ensure new RNode releases are able to work with existing mainnet.

Description

There might be a case when updated version of RNode cannot work with existing tuplespace, In this case node cannot start and throws
https://github.com/rchain/rchain/blob/81e96f69c60323079066075b001339e7b9fee067/casper/src/main/scala/coop/rchain/casper/Casper.scala#L103

There should be an integration test ensuring new version of nodes can work with existing network.

Activity

Show:
Will Qiu
October 29, 2019, 6:21 AM

Assignee

Will Qiu

Reporter

nutzipper

Priority

Medium

Components

None

Story Points

5

Epic Link

None

Fix versions

None

Labels

None
Configure